jFed is a Java-based framework
for testbed federation

What can I do with jFed?

  • jFed Experimenter GUI and CLI allow end-users to provision and manage experiments. Click here for a quick overview movie.
  • jFed Probe GUI and CLI assist testbed developers in testing their API implementations
  • jFed Automated tester GUI and CLI perform extensive full-automated tests of the testbed APIs and testbeds, in which the complete workflow of an experiment is followed. This tool is used as part of the Fed4FIRE testbed monitor.

To learn more about jFed, go to the features page.

Get started

If this is the first time that you use jFed, please check the dependencies. To start up one of the jFed GUI’s immediately, you can use the corresponding button below:

The latest version of jFed is only compatible with Java 8 or higher. We detected that you are using an older version.

Please upgrade to Java 8 to get access to the newest version. Otherwise, you can use the older jFed 5.3.2, which is Java 7-compatible.

jFed requires Java to run. We however couldn't detect a Java installation in your browser.

Please install the latest version of Java to continue.

The latest version of jFed is only compatible with Java 8 or higher. We detected that you are using an older version.

Please upgrade to Java 8 to get access to the newest version. Otherwise, you can use the older jFed 5.3.2, which is Java 7-compatible.

jFed requires Java to run. We however couldn't detect a Java installation in your browser.

Please install the latest version of Java to continue.

The latest version of jFed is only compatible with Java 8 or higher. We detected that you are using an older version.

Please upgrade to Java 8 to get access to the newest version. Otherwise, you can use the older jFed 5.3.2, which is Java 7-compatible.

jFed requires Java to run. We however couldn't detect a Java installation in your browser.

Please install the latest version of Java to continue.

The latest version of jFed is only compatible with Java 8 or higher. We detected that you are using an older version.

Please upgrade to Java 8 to get access to the newest version. Otherwise, you can use the older jFed 5.3.2, which is Java 7-compatible.

jFed requires Java to run. We however couldn't detect a Java installation in your browser.

Please install the latest version of Java to continue.

The latest version of jFed is only compatible with Java 8 or higher. We detected that you are using an older version.

Please upgrade to Java 8 to get access to the newest version. Otherwise, you can use the older jFed 5.3.2, which is Java 7-compatible.

jFed requires Java to run. We however couldn't detect a Java installation in your browser.

Please install the latest version of Java to continue.

All other tools can be accessed here.

Brought to you by

iMinds Research institue Ghent University Fed4FIRE